US Walmart shooting: Weapon purchased morning of attack
Incident Report for komatkamit
Update
We are continuing to investigate this issue.
Posted Nov 25, 2022 - 23:27 UTC
Investigating
A man who opened fire on co-workers at a Walmart in Virginia had just hours before legally purchased the handgun he used in the attack, officials say.

An update on Friday from city of Chesapeake officials also said the gunman did not have a criminal history.

Six people were killed in the Tuesday evening attack, all of whom were Walmart employees.

The gunman also died from a self-inflicted gunshot wound.

Police have not stated a motive for the shooting, but officials released a "Death Note" found on the gunman's phone that included perceived grievances he held against some of his colleagues.

"God forgive me for what I am going to do," the suspect concluded in the note.

Police have named the victims as Lorenzo Gamble, 43, Brian Pendleton, 38, Kellie Pyle, 52, Randall Blevins, 70, and Tyneka Johnson, 22.

On Friday, the city revealed name of the sixth victim: 16-year-old Fernando Chavez-Barron.

A Walmart spokesperson said in a statement to media that all of the victims worked for the company.

The gunman was identified by police as 31-year-old Andre Bing, a manager at the Walmart where the attack took place.

Police said he was armed with a 9mm handgun that was purchased at a local store, and multiple magazines.

Gun violence in the US explained in seven charts
A witness in the attack has said the gunman appeared to be targeting specific people.

Speaking to the Associated Press, Jessica Wilczewski said workers were gathered in the store's break room when the gunman opened fire.

"What I do know is that he made sure who he wanted dead, was dead," Ms Wilczewski said.

Chesapeake Mayor Rick West said a community vigil will be held on Monday to commemorate the victims.

The Virginia shooting came just days after a gunman opened fire at a LGBT nightclub in the US state of Colorado, killing five people and leaving 17 others with gunshot injuries.

This is not the first mass shooting at a Walmart store. Twenty-three people were killed in 2019 at a Walmart in El Paso, Texas. The gunman, who allegedly targeted Hispanics, is awaiting trial.

On Thursday, President Joe Biden called for stricter gun laws and said he is "going to try" to move on gun control before Republicans take control of the House of Representatives in January.
https://new.c.mi.com/my/post/377228
https://new.c.mi.com/my/post/379491
https://new.c.mi.com/my/post/375815
https://new.c.mi.com/my/post/377213
https://new.c.mi.com/my/post/377578
https://new.c.mi.com/my/post/377248
https://new.c.mi.com/my/post/375845
https://new.c.mi.com/my/post/379516
https://new.c.mi.com/th/post/150769
https://new.c.mi.com/th/post/151657
https://new.c.mi.com/th/post/152700
https://new.c.mi.com/th/post/151647
https://new.c.mi.com/th/post/153368
https://new.c.mi.com/th/post/151667
https://new.c.mi.com/th/post/152730
https://new.c.mi.com/th/post/152725
https://new.c.mi.com/my/post/376419
https://new.c.mi.com/my/post/377678
https://new.c.mi.com/my/post/377663
https://new.c.mi.com/my/post/376225
https://new.c.mi.com/my/post/377708
https://new.c.mi.com/my/post/377712
https://new.c.mi.com/my/post/379871
https://new.c.mi.com/my/post/380723
https://new.c.mi.com/my/post/382791
https://new.c.mi.com/my/post/379310
https://new.c.mi.com/my/post/377947
https://jemi.so/voir-smile-film-fr-complet-gratuit-en-francais-vostfr
https://reallygoodemails.com/asads
https://reallygoodemails.com/blackadamstreamingvf
https://www.runtheworld.today/app/invitation/48722
https://www.runtheworld.today/app/invitation/48723
https://www.runtheworld.today/app/invitation/48724
https://www.runtheworld.today/app/invitation/48725
https://www.runtheworld.today/app/invitation/48726
https://www.runtheworld.today/app/invitation/48727
https://www.runtheworld.today/app/invitation/48728
https://www.runtheworld.today/app/invitation/48729
https://www.runtheworld.today/app/invitation/48730
https://new.c.mi.com/my/post/383573
https://new.c.mi.com/my/post/383568
https://new.c.mi.com/my/post/385436
https://new.c.mi.com/my/post/383412
https://new.c.mi.com/my/post/385426
https://pastelink.net/t09fhx8p
https://paiza.io/projects/kK1Tj1nnrOlXho7AXe8r2A?language=php
https://ideone.com/eTkVZu
https://p.teknik.io/Q40U1
https://pasteio.com/xYkAdmtUOjjE
https://paste.ee/p/mEYyt
https://bitbin.it/vX4X1gs3/
https://notes.io/qcjSs
https://pastebin.com/eKu1sJPj
https://ide.geeksforgeeks.org/ac382a01-d638-4173-b332-9a08c4ea1ff3
https://controlc.com/1755aa28
https://paste2.org/75xMI8mV
https://paste.rs/phb
https://apaste.info/BtVY
https://justpaste.it/8c0kt
https://www.pastery.net/kjegxh/
https://rentry.co/wefn5
https://yamcode.com/6ig1fz67ve
https://www.posteezy.com/asdasd-2
https://tech.io/snippet/TRjJkra
https://paste.cutelyst.org/xorjVy4uS
http://paste.jp/f35041dd/
http://pastie.org/p/565BYDHDm8wJe4LRTv3hyq
https://jsfiddle.net/x8bjd4g0/
https://jsfiddle.net/x8bjd4g0/1/
https://rextester.com/AEC11323
https://paste.feed-the-beast.com/view/a4b09ce8
http://paste.akingi.com/aDLJpPVG
https://0paste.com/412066
https://paste.cutelyst.org/oDmXfScaS
https://telegra.ph/adsasd-11-25-2
http://pastie.org/p/5PAteQBSRTthGAXCiiHxpk
https://www.onfeetnation.com/profiles/blogs/hfgfghfgh
https://www.onfeetnation.com/photo/albums/sdasd-9
http://beterhbo.ning.com/profiles/blogs/asdasd-7
http://beterhbo.ning.com/forum/topics/asdsaddsa
http://beterhbo.ning.com/photo/albums/sdaasd
http://zacriley.ning.com/photo/albums/sdasd
http://zacriley.ning.com/profiles/blogs/ssfdsdfsdf
http://zacriley.ning.com/forum/topics/asdasd-4
http://taylorhicks.ning.com/photo/albums/sadasd-2
https://smarthealthadv.shivtr.com/forum_threads/3724633
https://paste.artemix.org/-/C-B_Fr
https://onecompiler.com/java/3yq2u2kjb
Posted Nov 25, 2022 - 23:26 UTC